On Tue, Feb 2, 2016 at 10:46 AM, Matthew Wilcox <willy@xxxxxxxxxxxxxxx> wrote: > On Tue, Feb 02, 2016 at 09:46:21AM -0800, Dan Williams wrote: >> What a about a super_operation? That seems the right level, given >> we're currently doing: >> >> inode->i_sb->s_bdev >> >> ...it does not seem terrible to instead do: >> >> inode->i_sb->s_op->get_block() > > The point is that filesystems have lots of different get_block operations, > and the right one to use depends not just on the inode, but also upon > what VFS function is being called, and in some filesystems the phase > of the moon, or the file open flags (so even inode->i_ops->get_block is > wrong; file->f_ops->get_block would be better, but of course we've lost > that by the point we're doing writeback). True, but in this case we're just trying to resolve the bdev for a inode / sector combination to already allocated storage. So get_block() is a misnomer, this is just get_bdev() to resolve a super_block-inode+sector tuple to a bdev for cases when s_bdev is the wrong answer. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html