Re: [PATCH 5/5] fs: add async read/write interfaces

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Jan 27, 2015 at 06:55:13PM +0100, Christoph Hellwig wrote:
> +void init_kernel_kiocb(struct kiocb *iocb, struct file *file, loff_t pos,
> +		void (*complete)(struct kiocb *iocb, ssize_t ret))
> +{
> +	iocb->ki_filp = file;
> +	iocb->ki_pos = pos;
> +	iocb->complete = complete;
> +}
> +EXPORT_SYMBOL_GPL(init_kernel_kiocb);

Could we please stop that nonsense?  Any non-GPL module that decides to
use that will simply open-code this oh-so-valuable piece of intellectual
property - all three assignments worth of it.

EXPORT_SYMBOL_GPL() is usually silly posturing - it's borderline
defensible if you are exporting deep guts of otherwise internal objects
and want to limit the scope of damage (but in that case you'd better
have a very good reason for having an export at all), but in cases
like this it's something better kept to alt.sex.masturbation.

I'm not fond of non-GPL modules, but this is simply ridiculous.
Use normal export.  The same goes for other two exports here.
--
To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [Samba]     [Device Mapper]     [CEPH Development]
  Powered by Linux