On Sat, Aug 25, 2012 at 06:55:04PM +0100, Al Viro wrote: > > Well, this could be simplified indeed, if I understand you correctly > > you propose just save f_mode in flexible array and use it instead > > of struct file, right? (which will require to rewrite code a bit) > > Yes. FWIW, proc_fill_cache() is really atrocious ;-/ Not to mention OK, thanks. I'm putting this cleanup task in my big todo list. Hope I'll manage on the next week with it. > anything else, if we ever get a negative dentry there, we have a dentry > leak. I don't think it's possible in practice, but... Furthermore, could you please elaborate, you mean this string? struct dentry *child, *dir = filp->f_path.dentry; > if (!child || IS_ERR(child) || !child->d_inode) > goto end_instantiate; this could be IS_ERR_OR_NULL i guess > inode = child->d_inode; > if (inode) { > ino = inode->i_ino; > type = inode->i_mode >> 12; > } > dput(child); > looks really weird - how can we possibly get !inode when we'd just > checked that child->inode is non-NULL? Moreover, that find_inode_number() > a bit below is also as weird as it gets - in effect, we repeat > d_lookup() we'd just done earlier. How *can* it get us anything? to be fair -- I don't know ;) I mean I didn't invent this function but it definitely could be cleaned up. That was partly a reason why I've moved fd related code to fd.c|h (base.c is really big in content already and it's always a problem at least for me to follow big "c" files). I can try to clean this code up, but not in this patch series, just to not mess the series even more. Cyrill -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html