On Thu, Jun 24, 2010 at 12:06:50PM +0200, Andi Kleen wrote: > npiggin@xxxxxxx writes: > > > Allow the shrinker to do per-zone shrinking. This means it is called for > > each zone scanned. The shrinker is now completely responsible for calculating > > and batching (given helpers), which provides better flexibility. > > Beyond the scope of this patch, but at some point this probably needs > to be even more fine grained. With large number of cores/threads in > each socket a "zone" is actually shared by quite a large number > of CPUs now and this can cause problems. Yes, possibly. At least it is a much better step than the big dumb global list. > > +void shrinker_add_scan(unsigned long *dst, > > + unsigned long scanned, unsigned long total, > > + unsigned long objects, unsigned int ratio) > > +{ > > + unsigned long long delta; > > + > > + delta = (unsigned long long)scanned * objects * ratio; > > + do_div(delta, total + 1); > > + delta /= (128ULL / 4ULL); > > Again I object to the magic numbers ... > > > + nr += shrink_slab(zone, 1, 1, 1, GFP_KERNEL); > > + if (nr >= 10) > > + goto again; > > And here. I don't like them either -- problem is they were inherited from the old code (actually 128 is the fixed point scale, I do have a define for it just forgot to use it). I don't know where 4 came from. And 10 is just a random number someone picked out of a hat :P > Overall it seems good, but I have not read all the shrinker callback > changes in all subsystems. Thanks for looking over it Andi. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html