On Fri, Jun 11, 2010 at 09:15:54PM -0700, Linus Torvalds wrote: > On Fri, Jun 11, 2010 at 8:57 PM, Nick Piggin <npiggin@xxxxxxx> wrote: > > > > Something like this > > > > fs/dcache.c | 14 ++++++++++++-- > > fs/super.c | 51 +++++++++++++++++++++++++++++++++++++++++++++------ > > 2 files changed, 57 insertions(+), 8 deletions(-) > > Ok, I have to admit that I didn't expect it to blow up quite that > badly - I thought it would add a line or two, not 50. In fairness I added a lot more comments and a bit of whitespace, accounting for about half of those lines added. > So wow I wonder if we should use your old approach instead, just make > it an 'official' thing. IOW, maybe we can use > "list_for_each_entry_safe()" after all, but simply introduce a > "reset_next_entry()" helper or something and make that be part of the > "calling convention" for those things. > > But I can live with the open-coded version too. It just is a bit more > code than I thought it would be. > > Anybody? I don't really have very strong opinions. I wouldn't mind a list macro to reset. I'd prefer the name match better with the iterator macro though. list_safe_reset_next()? -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html