On Wed, Jun 09, 2010 at 09:00:47AM -0400, Christoph Hellwig wrote: > > +static void evict(struct inode *inode, int delete) > > How about calling this evict_inode? That gives a better grepable > identifier in backtraces and also fits the tradition of other > wrappers for methods. > > > +{ > > + const struct super_operations *op = inode->i_sb->s_op; > > + > > + if (delete && op->delete_inode) { > > + op->delete_inode(inode); > > What's the point in having the local op variable? Shorter and more readable? See generic_delete_inode() in mainline for origin of that... -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html