Re: [Lsf-pc] [LSF/MM/BPF TOPIC] Reclamation interactions with RCU

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Mar 04, 2024 at 09:45:48AM +1100, NeilBrown wrote:
> I have in mind a more explicit statement of how much waiting is
> acceptable.
> 
> GFP_NOFAIL - wait indefinitely

Why not call it GFP_SMALL?  It wouldn't fail.  The size would have to be
less than some limit.  If the size was too large, that would trigger a
WARN_ON_ONCE().

I obviously understand that this duplicates the information in the size
parameter but the point is that GFP_SMALL allocations have been
reviewed, updated, and don't have error handling code.

We'd keep GFP_KERNEL which would keep the existing behavior.  (Which is
that it can sleep and it can fail).  I think that maps to GFP_RETRY but
GFP_RETRY is an uglier name.

People could still use __GFP_NOFAIL for larger allocations.

regards,
dan carpenter





[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [NTFS 3]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [NTFS 3]     [Samba]     [Device Mapper]     [CEPH Development]

  Powered by Linux