On Tue, Mar 05, 2024 at 09:29:50PM +0000, Al Viro wrote: > On Tue, Mar 05, 2024 at 03:08:18PM -0600, Bill O'Donnell wrote: > > - if ((bool)(*flags & SB_RDONLY) == sb_rdonly(sb)) > > + if ((bool)(fc->sb_flags & SB_RDONLY) == sb_rdonly(sb)) > > return 0; > > This is getting really annoying - let's just add > > static inline bool fc_rdonly(const struct fs_context *fc) > { > return fc->sb_flags & SB_RDONLY; > } > > and spell the above as > > if (fc_rdonly(fc) == sb_rdonly(sb)) > return 0; > > etc. Quite a few places have that open-coded... > Thanks for your review. I sent a v2, but I'll treat the suggested change to fs_context_core_code separately. -Bill