On Fri, Sep 04, 2009 at 07:51:37AM -0700, Daniel Walker wrote: > On Fri, 2009-09-04 at 16:51 +1000, npiggin@xxxxxxx wrote: > > +/* This should be called _only_ with a lock pinning the dentry */ > > +static inline struct dentry * __dget_locked_dlock(struct dentry > > *dentry) > > +{ > > + dentry->d_count++; > > + dentry_lru_del_init(dentry); > > + return dentry; > > +} > > + > > +static inline struct dentry * __dget_locked(struct dentry *dentry) > > +{ > > Could you run your series through checkpatch, and clean up at least any > errors you find.. Sure, I'll try to remember to do that at some point. fs/ code has a lot of space after *, which I don't always fix up (and arguably is a clearer way write pointer types). But yeah I'm happy to follow checkpatch style. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html