On Fri, 2009-09-04 at 16:51 +1000, npiggin@xxxxxxx wrote: > +/* This should be called _only_ with a lock pinning the dentry */ > +static inline struct dentry * __dget_locked_dlock(struct dentry > *dentry) > +{ > + dentry->d_count++; > + dentry_lru_del_init(dentry); > + return dentry; > +} > + > +static inline struct dentry * __dget_locked(struct dentry *dentry) > +{ Could you run your series through checkpatch, and clean up at least any errors you find.. Plus add your signed off, most (all?) aren't signed off.. Daniel -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html