On Fri, Nov 24, 2023 at 09:37:16AM +0200, Amir Goldstein wrote: > Since you like pre-git archeology... > > Mind digging up what this comment in fs.h is about: > > /* needed for stackable file system support */ > extern loff_t default_llseek(struct file *file, loff_t offset, int whence); Umm... I think it was about ecryptfs and its ilk, but it was a long time ago... <looks> 2.3.99pre6, along with exporting it: -/* for stackable file systems (lofs, wrapfs, etc.) */ -EXPORT_SYMBOL(add_to_page_cache); +/* for stackable file systems (lofs, wrapfs, cryptfs, etc.) */ +EXPORT_SYMBOL(default_llseek); +EXPORT_SYMBOL(dentry_open); Back then ->llseek == NULL used to mean default_llseek; that had been changed much later. And that was before vfs_llseek() as well, so any layered filesystem had to open-code it - which required default_llseek(). The comment is certainly stale, though - stackable filesystems do *not* need it (vfs_llseek() is there), but every file_operation that used to have NULL ->llseek does. > Or we can just remove it without digging up what the comment used > to refer to ;) Too late - it will have to be removed with that ;-)