> - v9fs_qid2ino(&st.qid), dt_type(&st)); > + v9fs_qid2ino(&st.qid), v9fs_dt_type(&st)); This adds an overly long line. Also renaming the v9fs dt_type seems like it should be a prep patch. > +/* Relationship between i_mode and the DT_xxx types */ This comment seems a bit terse. > +static inline unsigned char dt_type(umode_t mode) > +{ > + return ((mode) & S_IFMT) >> S_DT_SHIFT; No need for the inner braces.