On Mon, Jul 26, 2021 at 04:45:40PM +0200, Christoph Hellwig wrote: > On Mon, Jul 26, 2021 at 03:41:05PM +0100, Matthew Wilcox wrote: > > On Mon, Jul 26, 2021 at 12:27:56PM +0200, Christian Brauner wrote: > > > +/** > > > + * lookup_mapped_one_len - filesystem helper to lookup single pathname component > > > > Can we think about the name a bit? In the ur-times (2.3.99), we had > > lookup_dentry(), which as far as I can tell walked an entire path. > > That got augmented with lookup_one() which just walked a single path > > entry. That was replaced with lookup_one_len() which added the 'len' > > parameter. Now we have: > > > > struct dentry *try_lookup_one_len(const char *, struct dentry *, int); > > struct dentry *lookup_one_len(const char *, struct dentry *, int); > > struct dentry *lookup_one_len_unlocked(const char *, struct dentry *, int); > > struct dentry *lookup_positive_unlocked(const char *, struct dentry *, int); > > > > I think the 'len' part of the name has done its job, and this new > > helper should be 'lookup_one_mapped'. > > Heh. I'd drop the mapped as well as this should be the new normal > going ahead. I'm fine with either. Though lookup_one() is shorter and sounds nicest. :)