> + size_t poff = offset_in_folio(folio, *pos); > + size_t plen = min_t(loff_t, folio_size(folio) - poff, length); These variables are a little misnamed now. But I'm not sure what a better name would be. > + size_t off = (page - &folio->page) * PAGE_SIZE + > + bvec->bv_offset; Another use case for the helper I suggested earlier. Otherwise looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx>