On Mon, Jan 04, 2021 at 07:43:17AM -0700, Jens Axboe wrote: > > I've not put it into #for-next yet; yell if you see any problems with that > > branch, or it'll end up there ;-) > > Thanks Al - but you picked out of v3, not v4. Not that there are huge > changes between the two, from the posting of v4: > > - Rename LOOKUP_NONBLOCK -> LOOKUP_CACHED, and ditto for the RESOLVE_ > flag. This better explains what the feature does, making it more self > explanatory in terms of both code readability and for the user visible > part. > > - Remove dead LOOKUP_NONBLOCK check after we've dropped LOOKUP_RCU > already, spotted by Al. > > - Add O_TMPFILE to the checks upfront, so we can drop the checking in > do_tmpfile(). > > and it sounds like you did the last two when merging yourself. Yes - back when I'd posted that review. > I do like > LOOKUP_CACHED better than LOOKUP_NONBLOCK, mostly for the externally > self-documenting feature of it. What do you think? Agreed, especially since _NONBLOCK would confuse users into assumption that operation is actually non-blocking... > Here's the v4 posting, fwiw: > > https://lore.kernel.org/linux-fsdevel/20201217161911.743222-1-axboe@xxxxxxxxx/ Sorry, picked from the local branch that sat around since Mid-December ;-/ Fixed. Another change: ..._child part in unlazy_child() is misleading - it might as well be used for .. traversal, where dentry is usually the _parent_ of nd->path.dentry. The real constraint here is that dentry/seq pair had been valid next position at some point during the RCU walk. Renamed to try_to_unlazy_next(), (hopefully) fixed the comment... Updated variant force-pushed.