> > But we never generate FS_MODIFY|FS_ISDIR events so I don't think there's a > > big space for confusion (and I've deliberately used CHANGE instead of > > MODIFY to make the distinction even clearer). FWIW > > FANOTIFY_DIRENT_MODIFY_EVENTS would also look better than _FILENAME_EVENTS > > to me. > > > > Fair enough. I'll change to FANOTIFY_DIRENT_MODIFY_EVENTS > and similar named helpers and comments in fsnotify.h. > On second thought, if you don't object, I will opt for brevity and use: FANOTIFY_DIRENT_EVENTS. I don't thing that dropping the _MODIFY_ /_change part of the name is going to be a source of ambiguity. /* Notify this directory about a change in one of its directory entries. */ static inline int __fsnotify_dirent(struct inode *dir, __u32 mask, const unsigned char *file_name, u32 cookie) /* * Notify this dentry's parent about a change in the directory entry * associated with this dentry. * Unlike fsnotify_parent(), the event will be reported regardless of the * FS_EVENT_ON_CHILD mask on the parent inode * Safe to call with negative dentry, e.g. from fsnotify_nameremove() */ static inline int fsnotify_dirent(struct dentry *dentry, __u32 mask) Thanks, Amir.