>> + * current_time - Return FS time >> + * @inode: inode. >> + * >> + * Return the current time truncated to the time granularity supported by >> + * the fs. >> + * >> + * Note that inode and inode->sb cannot be NULL. >> + * Otherwise, the function warns and returns time without truncation. >> + */ >> +struct timespec current_time(struct inode *inode) > > Just a nitpick. Can we please rename that to fs_current_time() or something > similar which tells right away that this is a FS specific > function. current_time() is pretty generic and used in many places as > variable/argument name. I proposed this as one of the names before: https://lkml.org/lkml/2016/6/14/613 . But, decided against it because of the inode argument. If this is preferred, I will change the patches. There are only about 30 (20, outside of staging) current_time references outside of Documentation/ -Deepa -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html