On Thu, 2006-06-08 at 12:42 +0200, Herbert Poetzl wrote: > > diff -puN fs/namei.c~rmdir1 fs/namei.c > > --- lxc/fs/namei.c~rmdir1 2006-06-07 16:53:13.000000000 -0700 > > +++ lxc-dave/fs/namei.c 2006-06-07 16:53:13.000000000 -0700 > > @@ -2012,7 +2012,12 @@ static long do_rmdir(int dfd, const char > > error = PTR_ERR(dentry); > > if (IS_ERR(dentry)) > > goto exit2; > > + error = mnt_want_write(nd.mnt); > > + if (error) > > + goto exit3; > > error = vfs_rmdir(nd.dentry->d_inode, dentry); > > + mnt_drop_write(nd.mnt); > > +exit3: > > IMHO, for consistency this should be named similar in > all the different places, so maybe make that? > > out_put: > > or maybe: > > out_rdonly: > > (same goest for the following patches) > otherwise fine I'm not too set on it either way. I tried to be consistent with some of the style in the functions, especially when they had a _lot_ of goto conditions. This one is right on the cusp of where I want to rock the boat. ;) -- Dave - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html