On Wed, Jun 07, 2006 at 05:10:16PM -0700, Dave Hansen wrote: > > Elevate the write count during the vfs_rmdir() call. There > will be a lot of patches similar to this one coming up. > > Signed-off-by: Dave Hansen <haveblue@xxxxxxxxxx> > --- > > lxc-dave/fs/namei.c | 5 +++++ > 1 files changed, 5 insertions(+) > > diff -puN fs/namei.c~rmdir1 fs/namei.c > --- lxc/fs/namei.c~rmdir1 2006-06-07 16:53:13.000000000 -0700 > +++ lxc-dave/fs/namei.c 2006-06-07 16:53:13.000000000 -0700 > @@ -2012,7 +2012,12 @@ static long do_rmdir(int dfd, const char > error = PTR_ERR(dentry); > if (IS_ERR(dentry)) > goto exit2; > + error = mnt_want_write(nd.mnt); > + if (error) > + goto exit3; > error = vfs_rmdir(nd.dentry->d_inode, dentry); > + mnt_drop_write(nd.mnt); > +exit3: IMHO, for consistency this should be named similar in all the different places, so maybe make that? out_put: or maybe: out_rdonly: (same goest for the following patches) otherwise fine best, Herbert > dput(dentry); > exit2: > mutex_unlock(&nd.dentry->d_inode->i_mutex); > _ - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html