On Mon, Oct 29, 2012 at 12:30:47PM +0800, zwu.kernel@xxxxxxxxx wrote: > --- a/mm/readahead.c > +++ b/mm/readahead.c > @@ -19,6 +19,7 @@ > #include <linux/pagemap.h> > #include <linux/syscalls.h> > #include <linux/file.h> > +#include <linux/hot_tracking.h> > > /* > * Initialise a struct file's readahead state. Assumes that the caller has > @@ -138,6 +139,11 @@ static int read_pages(struct address_space *mapping, struct file *filp, > out: > blk_finish_plug(&plug); > > + /* Hot data tracking */ > + hot_update_freqs(mapping->host, (u64)(list_entry(pages->prev,\ > + struct page, lru)->index) << PAGE_CACHE_SHIFT, > + (u64)nr_pages * PAGE_CACHE_SIZE, 0); There's a stale \ at the end of the line, and I find this formatting hard to read. Does the following look acceptable? hot_update_freqs(mapping->host, (u64)(list_entry(pages->prev, struct page, lru)->index) << PAGE_CACHE_SHIFT, (u64)nr_pages * PAGE_CACHE_SIZE, 0); > + > return ret; > } > -- To unsubscribe from this list: send the line "unsubscribe linux-ext4" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html