On Mon, Mar 26, 2012 at 04:22:58PM +0300, Sami Liedes wrote: > Hmm, no, I don't think so? count==0 here iff we have tested as many > bits as the caller requested. So this code will bail out if the number > of bits to test is not large enough to even hit a byte boundary, or if > the last bit to test and the byte boundary coincide. Perhaps count > should be renamed to something like bits_left_to_test if it's > confusing now? Ah, you're right, my bad. I managed to confuse myself with !count. In cases where we're not dealing with a boolean value, it's actually better to write (count == 0), for this reason. > I agree that a regression test is needed. I'll look into writing that. If you could work on improving tst_bitmaps, that would be great. Thanks!! - Ted -- To unsubscribe from this list: send the line "unsubscribe linux-ext4" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html