On Tue, 2007-09-25 at 21:15 +0530, Aneesh Kumar K.V wrote: > > Dave Kleikamp wrote: > > On Tue, 2007-09-25 at 14:33 +0530, Aneesh Kumar K.V wrote: > >> ext4 file system layout contain different split members > >> like bg_block_bitmap and bg_block_bitmap_hi. Introduce > >> data type le32_t and le16_t to be used as the type of > >> these split members. This prevents these members frome > >> being accessed directly. Accesing them directly gives > >> a compiler warning. This helps in catching some BUGS > >> due to direct partial access of these split fields. > > > > Ugh. I don't like this typedef at all. It just makes the data type more > > confusing. > > > Confusing enough to make people look at them more carefully. > > > > > > > Why not just change the name of bg_block_bitmap to something like > > bg_block_bitmap_lo or _bg_block_bitmap? It should be clear from the > > name that it shouldn't be used without careful consideration. > > > > even if we rename the variables, I guess we would like to have helper functions > for accessing these values. That would mean the code is finally going to look more > or less the same except the typedef. I see that as a good thing. The typedef is the part I don't like. > But the typedef actually save us from serious > misuse of these variables. You could just as easily write code that misuses bg_block_bitmap->value, as you could bg_block_bitmap_lo. I actually think using a name that describes that it's only half-a-value is more clear. Shaggy -- David Kleikamp IBM Linux Technology Center - To unsubscribe from this list: send the line "unsubscribe linux-ext4" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html