On Wed, Apr 29, 2020 at 11:55:04PM +0200, Ard Biesheuvel wrote: > On Wed, 29 Apr 2020 at 23:53, Joe Perches <joe@xxxxxxxxxxx> wrote: > > > > On Wed, 2020-04-29 at 17:43 -0400, Arvind Sankar wrote: > > > On Wed, Apr 29, 2020 at 08:49:21PM +0200, Ard Biesheuvel wrote: > > > > On Wed, 29 Apr 2020 at 20:47, Joe Perches <joe@xxxxxxxxxxx> wrote: > > > > > On Wed, 2020-04-29 at 13:41 -0400, Arvind Sankar wrote: > > > > > > Use pr_efi_err instead of bare efi_printk for error messages. > > > > > > > > > > Perhaps it'd be better to rename pr_efi_err to eri_err > > > > > so it's clearer it's a typical efi_ logging function. > > > > > > > > > > $ git grep -w --name-only pr_efi_err | \ > > > > > xargs sed -i 's/\bpr_efi_err\b/efi_err/g' > > > > > > > > > > > > > Yeah, pr_efi_err() is probably not the best name > > > > > > Should I rename pr_efi/pr_efi_err to, say, efi_pr_info/efi_pr_error? > > > > Perhaps not use pr_ in the name at all. > > > > I suggest: > > > > pr_efi -> efi_info (or efi_debug or efi_dbg) > > (it is guarded by an efi_quiet flag, default: on) > > pr_efi_err -> efi_err > > > > Agreed. Shorter is better if there is no risk of confusion.. Ok, I'll use efi_info/efi_err. We could add debugging output as efi_debug later, enabled if efi=debug is specified. While we're here: most of the existing cases of pr_efi look like notice or info level, except maybe these two, which probably should be at least warnings? drivers/firmware/efi/libstub/arm64-stub.c 62: pr_efi("EFI_RNG_PROTOCOL unavailable, no randomness supplied\n"); drivers/firmware/efi/libstub/efi-stub.c 254: pr_efi("Ignoring DTB from command line.\n");