Hi All, As promised here is a follow-up series to my earlier sha256 series. Note I have only compiled and tested this series on x86_64 !! All changes to architecture specific code on other archs have not even been tested to compile! With that said most of these changes were done using my editors search - replace function so things should be fine... (and FWIW I did do a Kconfig hack to compile test the ccree change). The first patch in this series rename various file local functions / arrays to avoid conflicts with the new include/crypto/sha256.h, followed by a patch merging include/crypto/sha256.h into include/crypto/sha.h. The last patch makes use of this merging to remove a bit more code duplication, making sha256_generic use sha256_init and sha224_init from lib/crypto/sha256.c. An added advantage of this, is that this gives these 2 functions coverage by the crypto selftests. Regards, Hans