[linux-dvb] [PATCH] HD5000 Support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Taylor Jacob wrote:
> Do you need me to do anything else, or is what I posted enough?
> 
> What concerns do you have about the lgdt330x changes?  There is only 1 change
> necssary to lgdt330x necessary to make the HD5000 work (3303 Init setting
> registed 0x87 I believe it is) the rest are all the SNR/Signal changes I added
> in..
> 
> I have been quite stressed with my day job, so hopefully I can stay on top of
> this, please let me know if you need anything..
> 
> As for a sign off I am happy with what I submitted so of course I would sign off
>  on it.. :)

Are you saying that if I were to apply all the changes except for the 
changes to lgdt330x, that wouldn't work?

If so, then please regenerate your patches following the guidelines I 
wrote 2 emails ago... The reason why I want to look at the snr changes 
separately is because Mac explained that there are many problems with 
that feature, and that lgdt3302 behaves differently than lgdt3303 in 
that respect.  There is an email (from me) containing mac's quoted 
explanation.

So, please separate the patches such that the first patch is only card 
support without the snr changes, and the second patch with the snr 
changes can be applied after mac looks at it.  (he also has all the 
datasheets required)

I'd like to commit your card support patch ASAP, because people are out 
there already using the card.  I've already asked Mac to look at your 
snr changes, but it will be easier to deal with after first applying the 
card support patch.

About the sign-off... I know this might sound rediculous, but I actually 
need for you to provide your sign-off to me... As it is a signature, I 
need for your fingers (not mine) to push the buttons on the keyboard, 
resulting in a sign-off in this form:

Signed-off-by: Your Name <email@xxxxxxxxxxx>

Oh yes... I forgot to mention... Your card support patch had functions 
named for lgdt3303 -- These should all be changed to lgdt330x, as there 
is no reason those functions should be specific to lgdt3303 only ... 
What if another flexcop board comes out that uses the lgdt3302?  There 
is no reason those functions can't be reused.  Please rename the 
lgdt3303 --> lgdt330x in your next patch.

Also, I was curious about this stuff:

+	buf[0] = 0x86 | 0x18;
+	buf[1] = 0x50;
+	msg.len = 2;	
+	if ((err = i2c_transfer(&fc->i2c_adap, &msg, 1)) != 1) {
+		printk(KERN_WARNING "lgdt3303: %s error "
+			   "(addr %02x <- %02x, err = %i)\n",
+			   __FUNCTION__, buf[0], buf[1], err);
+		if (err < 0)
+			return err;
+		else
+			return -EREMOTEIO;
+	}


both cx88-dvb and dvb-bt8xx do this instead:

+	/* Set the Auxiliary Byte. */
+	buf[2] &= ~0x20;
+	buf[2] |= 0x18;
+	buf[3] = 0x50;
+	i2c_transfer(card->i2c_adapter, &msg, 1);


I don't have time to pull out all my references and specs right now.... 
I have no problem with your method, and it might have the same exact 
effect. If the code is doing the same exact thing, would it make more 
sense to try to re-use it again for the sake of uniformity?  Just take a 
look... That can be your call.

This last "nit" is really just an opinion/question.  I will apply that 
part exactly as you say... I am merely suggesting that another way 
*might* also work, although I could be wrong.

:-P


Thanks again.
-- 
Michael Krufky


[Index of Archives]     [Linux Media]     [Video 4 Linux]     [Asterisk]     [Samba]     [Xorg]     [Xfree86]     [Linux USB]

  Powered by Linux