On Fri, May 20, 2005 at 09:01:01PM +0200, Francois Romieu wrote: > +static int __av7110_budget_register(struct av7110 *av7110) > +{ > + struct dvb_demux *dvbdemux = &av7110->demux1; > + struct dmxdev *dmxdev = &av7110->dmxdev1; > + struct dmx_demux *dmx = &dvbdemux->dmx; > + > + if (!budgetpatch) > + goto out; I would call this av7110_budgetpatch_register() and move the budgetpatch test back into av7110_register(). (I think there is a convention that __ prefix is used when there is a function that doesn't do locking, and an equivalent function which does locking has the same name wihtout the __ prefix.) Johannes