Re: [PATCH 2/6] staging: ks7010: replace identifier retval with rc

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Mar 14, 2017 at 09:20:13PM +1100, Tobin C. Harding wrote:
> Code uses identifiers retval, ret, and rc all for function return
> values. It would be more readable if the whole driver used a single
> identifier for this task. Lets use 'rc' since it is the shortest.
> 
> Change retval -> rc

Ick, retval is much more readable, please use that.


> 
> Signed-off-by: Tobin C. Harding <me@xxxxxxxx>
> ---
>  drivers/staging/ks7010/ks7010_sdio.c | 72 ++++++++++++++++++------------------
>  1 file changed, 36 insertions(+), 36 deletions(-)
> 
> diff --git a/drivers/staging/ks7010/ks7010_sdio.c b/drivers/staging/ks7010/ks7010_sdio.c
> index f3ae9db..3da34b1 100644
> --- a/drivers/staging/ks7010/ks7010_sdio.c
> +++ b/drivers/staging/ks7010/ks7010_sdio.c
> @@ -89,7 +89,7 @@ static int ks7010_sdio_write(struct ks_wlan_private *priv, unsigned int address,
>  static void ks_wlan_hw_sleep_doze_request(struct ks_wlan_private *priv)
>  {
>  	unsigned char rw_data;
> -	int retval;
> +	int rc;
>  
>  	DPRINTK(4, "\n");
>  
> @@ -98,9 +98,9 @@ static void ks_wlan_hw_sleep_doze_request(struct ks_wlan_private *priv)
>  
>  	if (atomic_read(&priv->sleepstatus.status) == 0) {
>  		rw_data = GCR_B_DOZE;
> -		retval =
> +		rc =
>  		    ks7010_sdio_write(priv, GCR_B, &rw_data, sizeof(rw_data));

Also note that this could have been moved up to be on one line, so I'll
reject this patch anyway :)

thanks,

greg k-h
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux