On Fri, Jun 10, 2016 at 09:47:58PM -0400, David Kershner wrote: > Resending due to imcomplete distribution list. > > This patchset comprises the first 26 patches of the previously-submitted > patchset (but retracted): > > [PATCH v4 00/29] Fixed issues raised by tglx, then move visorbus to > drivers/virt > > then adds 2 patches to visorinput that: > * fixes a device initialization race condition > * converts a semaphore to a mutex > > As described in the email NAKing the previously-submitted patchset, > the reason we are re-submitting this now is to make things a bit > cleaner by separating the fixes we need to make to the code in > staging from the patchset that actually moves the code out of staging. > > The intent of this patchset is to fix all known outstanding > issues with code in drivers/staging/unisys/, so that subsequent > patchsets can move these drivers out of staging. > > tglx: The following patchset fixes issues you raised during your > code review of visorbus on 5/18, and visorinput on 6/1. > > Converts visorbus to use a kernel timer for periodic device-specific > callbacks instead of a workqueue, making the implementation in > periodic_work.c and periodic_work.h no longer necessary. These files > are then deleted. > > The visordriver_callback_lock has been switched to a mutex. > > Several module parameters and structures were removed that were no > longer being used. > > Bryan Thompson (4): > staging: unisys: visorbus: Make visordriver_callback_lock a mutex > staging: unisys: visorbus: Remove unnecessary EXPORT_SYMBOL statements > staging: unisys: visorbus: Remove unused functions > staging: unisys: Remove reference to unused STANDALONE_CLIENT > > David Binder (13): > staging: unisys: visorbus: remove unused module parameters > staging: unisys: visorbus: remove unused struct > staging: unisys: visorbus: modify format string to match argument > staging: unisys: visornic: Correct comment spelling mistake > staging: unisys: include: Remove thread-related enum members > staging: unisys: visorbus: fix commenting in vbusdevinfo.h > staging: unisys: visorbus: fix commenting in visorbus_main.c > staging: unisys: visorbus: fix visorchannel.c comments > staging: unisys: visorbus: Rectify commenting in visorchipset.c > staging: unisys: visorbus: Move visorbus-unique functions to private > header > staging: unisys: visorbus: rectify kerneldoc comment for struct > staging: unisys: visorbus: Remove notifier-related code from visorbus > staging: unisys: visorbus: Rename function to follow existing > convention > > David Kershner (1): > staging: unisys: Move vbushelper.h to visorbus directory > > Erik Arfvidson (2): > staging: unisys: visorbus: remove return values for write_vbus > functions > staging: unisys: visorbus: check parahotplug_request_complete_result > > Tim Sell (8): > staging: unisys: visorbus: removed unused periodic_test_workqueue > staging: unisys: visorinput: remove unnecessary locking > staging: unisys: visorbus: use kernel timer instead of workqueue > staging: unisys: visorbus: remove periodic_work.h/.c > staging: unisys: visorbus: remove unused parameter from function > staging: unisys: visorbus: fix visorbus_private.h comments > staging: unisys: visorinput: ensure proper locking wrt creation & ints > staging: unisys: visorinput: make lock_visor_dev a mutex > > drivers/staging/unisys/include/guestlinuxdebug.h | 4 +- > drivers/staging/unisys/include/periodic_work.h | 40 -- > drivers/staging/unisys/include/vbushelper.h | 46 -- > drivers/staging/unisys/include/visorbus.h | 80 +-- > drivers/staging/unisys/visorbus/Makefile | 1 - > drivers/staging/unisys/visorbus/periodic_work.c | 204 ------- > drivers/staging/unisys/visorbus/vbusdeviceinfo.h | 65 ++- > drivers/staging/unisys/visorbus/vbushelper.h | 46 ++ > drivers/staging/unisys/visorbus/visorbus_main.c | 615 +++++++++++---------- > drivers/staging/unisys/visorbus/visorbus_private.h | 73 ++- > drivers/staging/unisys/visorbus/visorchannel.c | 269 +++------ > drivers/staging/unisys/visorbus/visorchipset.c | 434 ++++++++------- > drivers/staging/unisys/visorinput/visorinput.c | 141 +++-- > drivers/staging/unisys/visornic/visornic_main.c | 2 +- > 14 files changed, 879 insertions(+), 1141 deletions(-) > delete mode 100644 drivers/staging/unisys/include/periodic_work.h > delete mode 100644 drivers/staging/unisys/include/vbushelper.h > delete mode 100644 drivers/staging/unisys/visorbus/periodic_work.c > create mode 100644 drivers/staging/unisys/visorbus/vbushelper.h > > -- > 1.9.1 > Series Acked-By: Neil Horman <nhorman@xxxxxxxxxxxxx> _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel