Hi Gustavo, s/__64/__u64/ in the commit message. On 29 January 2016 at 23:20, Gustavo Padovan <gustavo@xxxxxxxxxxx> wrote: > From: Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx> > > Making fence_info a pointer enables us to extend the struct in the future > without breaking the ABI. > > Signed-off-by: Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx> > diff --git a/drivers/staging/android/uapi/sync.h b/drivers/staging/android/uapi/sync.h > index ed281fc..9f07aa7 100644 > --- a/drivers/staging/android/uapi/sync.h > +++ b/drivers/staging/android/uapi/sync.h > @@ -54,7 +54,7 @@ struct sync_file_info { > char name[32]; > __s32 status; > > - __u8 fence_info[0]; > + __u64 *fence_info; I believe you misinterpreted what was meant with "_u64 pointer". As the storage use for of a pointer varies across 32/64 bit arch, we explicitly use a variable type that is large enough (and consistent) for both cases. Thus the above should be + __u64 fence_info; Hope this clarifies things. -Emil _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel