From: Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx> Hi, This patch series clean up IOCTLs and abi of sync framework and it is a follow up on the clean up series I've sent on Jan 21: http://thread.gmane.org/gmane.comp.video.dri.devel/145509 The main changes here are: * remove of SYNC_WAIT ioctl, poll() should be used instead. * rename some structs and macros to better reflect the new internal names. * clean up and improve ABI on SYNC_IOC_FILE_INFO * add flags filed to all ABI structs Please review, thanks! Gustavo Padovan (10): staging/android: remove SYNC_WAIT ioctl staging/android: rename sync_pt_info to fence_info staging/android: rename sync_file_info_data to sync_file_info staging/android: remove driver_data from struct fence_info staging/android: remove len field from struct fence_info staging/android: turn fence_info into a __64 pointer staging/android: add num_fences field to struct sync_file_info staging/android: rename SYNC_IOC_FENCE_INFO staging/android: add flags member to sync ioctl structs staging/android: remove redundant comments on sync_merge_data drivers/staging/android/sw_sync.c | 14 ----- drivers/staging/android/sync.c | 113 +++++++---------------------------- drivers/staging/android/sync.h | 20 ------- drivers/staging/android/trace/sync.h | 44 -------------- drivers/staging/android/uapi/sync.h | 45 +++++++------- 5 files changed, 40 insertions(+), 196 deletions(-) -- 2.5.0 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel