On Fri, Oct 02, 2015 at 09:45:44AM +0200, Arend van Spriel wrote: > On 10/01/2015 03:43 PM, Chaehyun Lim wrote: > >This patch replaces int8_t with s8 that is a preferred type. > > > >Signed-off-by: Chaehyun Lim <chaehyun.lim@xxxxxxxxx> > >--- > > drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 6 +++--- > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > >diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c > >index d781003..56c97c9 100644 > >--- a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c > >+++ b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c > >@@ -263,9 +263,9 @@ static void clear_duringIP(unsigned long arg) > > g_obtainingIP = false; > > } > > > >-int8_t is_network_in_shadow(tstrNetworkInfo *pstrNetworkInfo, void *pUserVoid) > >+s8 is_network_in_shadow(tstrNetworkInfo *pstrNetworkInfo, void *pUserVoid) > > It seems to make more sense to use bool type here. That doesn't work, but you're right that the function is poorly named. It could be renamed to get_ap_index_or_something() in a later patch. Returning directly is also a good idea. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel