I haven't seen any bugs caused by lack of type safety with "!foo"... I prefer !foo because it is more common in the kernel and I think it's easier to read but I don't feel strongly about this. I kind of hate "if (foo != NULL) though, because it's a double negative. But I really hate when people start adding the "!= 0" on to all their conditions. if (frob() != 0) Also: if (a + b != 0) People do this all the time instead of "if (a || b)" and I don't know why... regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel