On Tuesday, June 12, 2012 12:50 PM, Dan Carpenter wrote: > On Tue, Jun 12, 2012 at 11:59:55AM -0700, H Hartley Sweeten wrote: >> for (i = 0; i < num_subdevices; ++i) { >> - dev->subdevices[i].device = dev; >> - dev->subdevices[i].async_dma_dir = DMA_NONE; >> - spin_lock_init(&dev->subdevices[i].spin_lock); >> - dev->subdevices[i].minor = -1; >> + s = dev->subdevices + i; > > You don't have to resend, but I think this would look better as: > > s = &dev->subdevices[i]; I don't disagree but the "dev->subdevices +i" format is consistently used in all the comedi stuff. If the format above is preferred we should probably update everything, >> + s->device = dev; >> + s->async_dma_dir = DMA_NONE; >> + spin_lock_init(&s->spin_lock); >> + s->minor = -1; >> } > > Btw, this patchset is great. Nice. Thanks! Hartley _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel