Re: [PATCH 2/2] staging: kpc2000: kpc_dma: rename show function per convention

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Oct 21, 2020 at 07:50:31AM +0200, Greg Kroah-Hartman wrote:
> On Wed, Oct 21, 2020 at 10:40:21AM +0530, Deepak R Varma wrote:
> > Rename show_engine_regs to engine_regs_show as per the convention
> > followed. Issue reported by checkpatch script.
> > 
> > Signed-off-by: Deepak R Varma <mh12gx2825@xxxxxxxxx>
> > ---
> >  drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c b/drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c
> > index 7698e5ef2a7c..b6d1afbd452d 100644
> > --- a/drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c
> > +++ b/drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c
> > @@ -50,7 +50,7 @@ static void kpc_dma_del_device(struct kpc_dma_device *ldev)
> >  }
> >  
> >  /**********  SysFS Attributes **********/
> > -static ssize_t  show_engine_regs(struct device *dev, struct device_attribute *attr, char *buf)
> > +static ssize_t  engine_regs_show(struct device *dev, struct device_attribute *attr, char *buf)
> >  {
> >  	struct kpc_dma_device *ldev;
> >  	struct platform_device *pldev = to_platform_device(dev);
> > @@ -80,7 +80,7 @@ static ssize_t  show_engine_regs(struct device *dev, struct device_attribute *at
> >  		ldev->desc_completed
> >  	);
> >  }
> > -static DEVICE_ATTR(engine_regs, 0444, show_engine_regs, NULL);
> > +static DEVICE_ATTR(engine_regs, 0444, engine_regs_show, NULL);
> 
> Shouldn't this just be using a DEVICE_ATTR_RO() macro instead?  Make
> that change and the name will be fixed up at the same time.
> 

Thank you for the feedback. I will review what the mentioned macro does
and how it can be implemented. Will send a revised patch with the change
suggested.

> And did checkpatch really complain about this?  What was the actual
> message it produced?

Yes, the WARNING message from checkpatch was:

WARNING: Consider renaming function(s) 'show_engine_regs' to 'engine_regs_show'                     
+#82: FILE: drivers/staging/kpc2000/kpc_dma/kpc_dma_driver.c:82:                                     
+}    


> 
> thanks,
> 
> greg k-h
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux