On Thu, 18 Oct 2018 09:40:00 +0200 Lars-Peter Clausen <lars@xxxxxxxxxx> wrote: > On 10/18/2018 09:28 AM, Phil Reid wrote: > [...] > >> + chip->rdwr_pin = devm_gpiod_get(&spi_dev->dev, "rdwr", GPIOD_IN); > >> + if (IS_ERR(chip->rdwr_pin)) { > >> + ret = PTR_ERR(chip->rdwr_pin); > >> + dev_err(&spi_dev->dev, "Failed to request rdwr GPIO: %d\n", > >> + ret); > >> return ret; > >> } > >> - gpio_direction_input(chip->rdwr_pin); > > > > The RD/WR pin is an input to the AD78xx. So this doesn't make sense being > > GPIOD_IN. > > One thing at a time. This patch is a straight forward conversion to the GPIO > descriptor interface. It keeps the existing semantics of the driver as they are. > > Now these semantics are obviously wrong and should be fixed but that should > be a separate patch from changing the interface. Agreed. Useful to raise these issues however, and I've added a note to the patch to bring this to anyone's attention should they be interesting. Thanks, Jonathan _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel