From: Todd Poynor <toddpoynor@xxxxxxxxxx> Various fixes mainly from the chromium review of the gasket and apex drivers. More to come. Todd Poynor (32): staging: gasket: remove X86 Kconfig restriction staging: gasket: fix typo in apex_enter_reset staging: gasket: fix typo in gasket_core.h comments staging: gasket: whitespace fix in gasket_page_table_init staging: gasket: remove driver registration on class creation failure staging: gasket: hold mutex on gasket driver unregistration staging: gasket: Return EBUSY on mapping create when already in use staging: gasket: Remove stale pointers on error allocating attr array staging: gasket: convert gasket_mmap_has_permissions to bool return staging: gasket: fix gasket_wait_with_reschedule timeout return code staging: gasket: gasket_wait_with_reschedule use msleep staging: gasket: gasket_wait_with_reschedule simplify logic staging: gasket: gasket_wait_with_reschedule use 32 bits of retry count staging: gasket: bail out of reset sequence on device callback error staging: gasket: drop gasket_cdev_get_info, use container_of staging: gasket: always allow root open for write staging: gasket: annotate ioctl arg with __user staging: gasket: gasket_enable_dev remove unnecessary variable staging: gasket: remove code for no physical device staging: gasket: fix class create bug handling staging: gasket: remove unnecessary code in coherent allocator staging: gasket: don't treat no device reset callback as an error staging: gasket: gasket_mmap return error instead of valid BAR index staging: gasket: apex_clock_gating simplify logic, reduce indentation staging: gasket: apex_ioctl_check_permissions use bool return type staging: gasket: gasket page table functions use bool return type staging: gasket: remove else clause after return in if clause staging: gasket: fix comment syntax in apex.h staging: gasket: remove unnecessary parens in page table code staging: gasket: gasket_mmap use PAGE_MASK staging: gasket: remove extra parens in gasket_write_mappable_regions staging: gasket: fix multi-line comment syntax in gasket_core.h Changes from v2: staging: gasket: Return EBUSY on mapping create when already in use Update commit text for clarity: why EBUSY is better than EINVAL here. staging: gasket: gasket_wait_with_reschedule use msleep Update commit text for clarity: why msleep is better than schedule_timeout here. staging: gasket: gasket_wait_with_reschedule return when condition hit Renamed: staging: gasket: gasket_wait_with_reschedule simplify logic Update commit text for clarity: improved description of change. Remove extraneous condition check and a return statement now impossible to reach. staging: gasket: always allow root open for write Add change that accidentally went into the below patch in v2. Normalize file mode bitwise ANDs to zero or one values. Dropped Reviewed-by from Dmitry Torokhov since this has changed. staging: gasket: annotate ioctl arg with __user Remove stray change from v2, now moved into the above patch in v3. staging: gasket: remove else clause after return in if clause Don't break line that doesn't need it after indentation reduced. staging: gasket: gasket_mmap use PAGE_MASK Update commit text for clarity: why ~PAGE_MASK is better than PAGE_SIZE - 1 here. staging: gasket: apex_clock_gating simplify logic, reduce indentation Unbreak line that no longer needs a break after re-indent. Unchanged from v2: staging: gasket: remove X86 Kconfig restriction staging: gasket: fix typo in apex_enter_reset staging: gasket: fix typo in gasket_core.h comments staging: gasket: whitespace fix in gasket_page_table_init staging: gasket: remove driver registration on class creation failure staging: gasket: hold mutex on gasket driver unregistration staging: gasket: Remove stale pointers on error allocating attr array staging: gasket: convert gasket_mmap_has_permissions to bool return staging: gasket: fix gasket_wait_with_reschedule timeout return code staging: gasket: gasket_wait_with_reschedule use 32 bits of retry count staging: gasket: bail out of reset sequence on device callback error staging: gasket: drop gasket_cdev_get_info, use container_of staging: gasket: gasket_enable_dev remove unnecessary variable staging: gasket: remove code for no physical device staging: gasket: fix class create bug handling staging: gasket: remove unnecessary code in coherent allocator staging: gasket: don't treat no device reset callback as an error staging: gasket: gasket_mmap return error instead of valid BAR index staging: gasket: apex_ioctl_check_permissions use bool return type staging: gasket: gasket page table functions use bool return type staging: gasket: fix comment syntax in apex.h staging: gasket: remove unnecessary parens in page table code staging: gasket: remove extra parens in gasket_write_mappable_regions staging: gasket: fix multi-line comment syntax in gasket_core.h drivers/staging/gasket/Kconfig | 2 +- drivers/staging/gasket/apex.h | 7 +- drivers/staging/gasket/apex_driver.c | 77 ++++++-------- drivers/staging/gasket/gasket_core.c | 115 ++++++++------------- drivers/staging/gasket/gasket_core.h | 11 +- drivers/staging/gasket/gasket_ioctl.c | 95 +++++++++-------- drivers/staging/gasket/gasket_ioctl.h | 4 +- drivers/staging/gasket/gasket_page_table.c | 66 ++++++------ drivers/staging/gasket/gasket_page_table.h | 8 +- drivers/staging/gasket/gasket_sysfs.c | 4 +- 10 files changed, 177 insertions(+), 212 deletions(-) -- 2.18.0.203.gfac676dfb9-goog _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel