> /* > * Allocate new object. This may result in rather complicated > * operations, including fld queries, inode loading, etc. > */ > o = lu_object_alloc(env, dev, f, conf); > - if (IS_ERR(o)) > + if (unlikely(IS_ERR(o))) > return o; > This is an unrelated and totally pointless. likely/unlikely annotations hurt readability, and they should only be added if it's something which is going to show up in benchmarking. lu_object_alloc() is already too slow for the unlikely() to make a difference and anyway IS_ERR() has an unlikely built in so it's duplicative... Anyway, I understand that Intel has been ignoring kernel.org instead of sending forwarding their patches properly so you're doing a difficult and thankless job... Thanks for that. I'm sure it's frustrating to look at these patches for you as well. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel