On Sun, May 06, 2018 at 03:03:02PM -0700, Nathan Chancellor wrote: > Fixes checkpatch.pl warnings. > > Signed-off-by: Nathan Chancellor <natechancellor@xxxxxxxxx> > --- > drivers/staging/ks7010/ks_hostif.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/drivers/staging/ks7010/ks_hostif.c b/drivers/staging/ks7010/ks_hostif.c > index a2833707e0bf..094f8c11b4ab 100644 > --- a/drivers/staging/ks7010/ks_hostif.c > +++ b/drivers/staging/ks7010/ks_hostif.c > @@ -35,7 +35,7 @@ static inline u8 get_byte(struct ks_wlan_private *priv) > { > u8 data; > > - data = *(priv->rxp)++; > + data = *priv->rxp++; Ick, no, the original is correct here. The changed one is now harder to read, I have to go look up order of operations here to figure this out :( _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel