On Tue, Aug 22, 2017 at 02:57:49PM +0530, Rishabh Hardas wrote: > On Sat, Aug 19, 2017 at 09:47:28PM -0700, Joe Perches wrote: > > On Wed, 2017-08-16 at 10:31 +0300, Dan Carpenter wrote: > > > On Wed, Aug 16, 2017 at 10:53:18AM +0530, Rishabh Hardas wrote: > > > > @@ -143,10 +142,13 @@ struct pi433_rx_cfg { > > > > > > > > #define PI433_IOC_MAGIC 'r' > > > > > > > > -#define PI433_IOC_RD_TX_CFG _IOR(PI433_IOC_MAGIC, PI433_TX_CFG_IOCTL_NR, char[sizeof(struct pi433_tx_cfg)]) > > > > -#define PI433_IOC_WR_TX_CFG _IOW(PI433_IOC_MAGIC, PI433_TX_CFG_IOCTL_NR, char[sizeof(struct pi433_tx_cfg)]) > > > > - > > > > -#define PI433_IOC_RD_RX_CFG _IOR(PI433_IOC_MAGIC, PI433_RX_CFG_IOCTL_NR, char[sizeof(struct pi433_rx_cfg)]) > > > > -#define PI433_IOC_WR_RX_CFG _IOW(PI433_IOC_MAGIC, PI433_RX_CFG_IOCTL_NR, char[sizeof(struct pi433_rx_cfg)]) > > > > +#define PI433_IOC_RD_TX_CFG _IOR(PI433_IOC_MAGIC, PI433_TX_CFG_IOCTL_NR,\ > > > > + char[sizeof(struct pi433_tx_cfg)]) > > > > +#define PI433_IOC_WR_TX_CFG _IOW(PI433_IOC_MAGIC, PI433_TX_CFG_IOCTL_NR,\ > > > > + char[sizeof(struct pi433_tx_cfg)]) > > > > +#define PI433_IOC_RD_RX_CFG _IOR(PI433_IOC_MAGIC, PI433_RX_CFG_IOCTL_NR,\ > > > > + char[sizeof(struct pi433_rx_cfg)]) > > > > +#define PI433_IOC_WR_RX_CFG _IOW(PI433_IOC_MAGIC, PI433_RX_CFG_IOCTL_NR,\ > > > > + char[sizeof(struct pi433_rx_cfg)]) > > > > > > > > > These don't help readability. The original was better. > > > > The original wasn't any good either. > > > > It'd be better to avoid the macros altogether > > as almost all are use-once. > > > > > So should I keep this as it is or remove the macros ? > Because as Dan said the corrections that I made aren't goo either. > Find a way to correct it which makes the code more readable than it was before. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel