> I like that, but keep the first patch as a refactoring patch only, and > then in a *new* patch 2 you add the rv32 specific code (sltu and > pseudo instructions + the xlen preprocessor check + copyright-things > ;-)). Patch 3 will be the old patch 2. Wdyt? Thanks! I'll make sure that patch 1 is for renaming bpf_jit_comp.c and factoring code out. Do you think it's reasonable to add the RV32-specific code to the header in the same patch that adds the RV32 JIT implementation (patch 2)? It might make sense to commit them together. The full plan for v5 would be: Patch 1 - Refactor existing code to bpf_jit.h and bpf_jit_core.c + Including the minor modifications to build_body() and bpf_int_jit_compile() (These are unrelated to RV32 and we could forego these tweaks). + Also making emit_insn and build_{prologue,epilogue} non-static and renaming them to be prefixed with "bpf_jit_". - Rename bpf_jit_comp.c to bpf_jit_comp64.c Patch 2 - Add the RV32 BPF JIT implementation to bpf_jit_comp32.c and RV32-specific changes to bpf_jit.h. Patch 3 - Update documentation. Patch 4 - Update MAINTAINERS. Thanks again, Luke