On Tue, Dec 17, 2013 at 04:16:56PM +0100, Marek Vasut wrote: > On Tuesday, December 17, 2013 at 02:49:25 PM, Huang Shijie wrote: > > On Tue, Dec 17, 2013 at 02:05:55PM +0100, Marek Vasut wrote: > > > On Monday, December 16, 2013 at 09:58:45 AM, Huang Shijie wrote: > > > > +struct spi_nor { > > + struct mtd_info *mtd; > > > > + struct mutex lock; > > > > + > > > > + /* pointer to a spi device */ > > > > + struct device *dev; > > > > + u32 page_size; > > > > + u8 addr_width; > > > > + u8 erase_opcode; > > > > + u8 read_opcode; > > > > + u8 read_dummy; > > > > + u8 program_opcode; > > > > + enum read_mode flash_read; > > > > + bool sst_write_second; > > > > + struct spi_nor_xfer_cfg cfg; > > > > > > You do want to split the function pointers below and the device > > > configuration above into separate structures. > > > > sorry, i prefer to keep them in one data structrue, just like the > > nand_chip{} does. > Take @read_reg for example, currently, we call it with nor->read_reg(); If we add a new data structrue for these hooks, we wil call it with nor->ops->read_reg(). So just like the nand_chip{}, make the code more simple. thanks Huang Shijie -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html