On Tuesday, December 17, 2013 at 02:49:25 PM, Huang Shijie wrote: > On Tue, Dec 17, 2013 at 02:05:55PM +0100, Marek Vasut wrote: > > On Monday, December 16, 2013 at 09:58:45 AM, Huang Shijie wrote: > > > +struct spi_nor { > > + struct mtd_info *mtd; > > > + struct mutex lock; > > > + > > > + /* pointer to a spi device */ > > > + struct device *dev; > > > + u32 page_size; > > > + u8 addr_width; > > > + u8 erase_opcode; > > > + u8 read_opcode; > > > + u8 read_dummy; > > > + u8 program_opcode; > > > + enum read_mode flash_read; > > > + bool sst_write_second; > > > + struct spi_nor_xfer_cfg cfg; > > > > You do want to split the function pointers below and the device > > configuration above into separate structures. > > sorry, i prefer to keep them in one data structrue, just like the > nand_chip{} does. Can you explain why? > > > + /* for write_reg */ > > > + u8 cmd_buf[SPI_NOR_MAX_CMD_SIZE]; > > > + > > > + /* > > > + * Do some work before or after we run these operations: > > > + * read/write/erese/lock/unlock > > > > Proper kernel-doc style comments for this structure would be nice. > > Do you mean the style used by nand_chip{}? Yes. See Documentation/kernel-doc-nano-HOWTO.txt Best regards, Marek Vasut -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html