Re: [RFC 02/11] hwmon: (core) Rename last parameter of devm_hwmon_register_with_info()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 5/4/23 00:57, James Seo wrote:
Change the name of the groups parameter of
devm_hwmon_device_register_with_info() to extra_groups to
match the name given by the hwmon API reference and in
hwmon_device_register_with_info().

Signed-off-by: James Seo <james@xxxxxxxxxx>
---
  drivers/hwmon/hwmon.c | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/hwmon/hwmon.c b/drivers/hwmon/hwmon.c
index 573b83b6c08c..5f205686065e 100644
--- a/drivers/hwmon/hwmon.c
+++ b/drivers/hwmon/hwmon.c
@@ -1029,7 +1029,7 @@ EXPORT_SYMBOL_GPL(devm_hwmon_device_register_with_groups);
   * @name:	hwmon name attribute
   * @drvdata:	driver data to attach to created device
   * @chip:	pointer to hwmon chip information
- * @groups:	pointer to list of driver specific attribute groups
+ * @extra_groups: pointer to list of driver specific attribute groups
   *
   * Returns the pointer to the new device. The new device is automatically
   * unregistered with the parent device.
@@ -1038,7 +1038,7 @@ struct device *
  devm_hwmon_device_register_with_info(struct device *dev, const char *name,
  				     void *drvdata,
  				     const struct hwmon_chip_info *chip,
-				     const struct attribute_group **groups)
+				     const struct attribute_group **extra_groups)

Please please please no such changes. I don't want to have to deal with
patch wars just because people believe variables should have other names.

Such changes add zero value unless one counts wasted review time as a "value".

Guenter

  {
  	struct device **ptr, *hwdev;
@@ -1050,7 +1050,7 @@ devm_hwmon_device_register_with_info(struct device *dev, const char *name,
  		return ERR_PTR(-ENOMEM);
hwdev = hwmon_device_register_with_info(dev, name, drvdata, chip,
-						groups);
+						extra_groups);
  	if (IS_ERR(hwdev))
  		goto error;




[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux FS]     [Yosemite Forum]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux