Hi Babu, On 3/16/2023 1:31 PM, Moger, Babu wrote: > On 3/15/23 13:33, Reinette Chatre wrote: >> On 3/2/2023 12:24 PM, Babu Moger wrote: >>> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c >>> index 15ea5b550fe9..3c86506e54c1 100644 >>> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c >>> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c >>> @@ -3163,7 +3163,7 @@ static int mkdir_rdt_prepare(struct kernfs_node *parent_kn, >>> { >>> struct rdtgroup *prdtgrp, *rdtgrp; >>> struct kernfs_node *kn; >>> - uint files = 0; >>> + uint fflags = 0; >> >> Hoe does changing the variable name from "files" to "fflags" simplify >> the code? > > I should have said readability of the code. Its actually fflags we are > passing to rdtgroup_add_files. While changing flags below, I changed the > variable name to fflags. You are correct in that it is the actual fflags parameter but what it reflects is which files will be created. I do not find that using "files" makes the code unreadable. Reinette