Re: [PATCH v3 2/7] x86/resctrl: Remove few unnecessary rftype flags

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Reinette,

On 3/15/23 13:33, Reinette Chatre wrote:
> Hi Babu,
> 
> On 3/2/2023 12:24 PM, Babu Moger wrote:
>> Remove few unnecessary rftype flags and simplify the code. This is done
> 
> Please drop "few" (here and in subject).

Sure.

> 
>> to further cleanup the code eventually.
> 
> Could you please be specific? "further cleanup the code
> eventually" is too vague. I do not understand what is meant
> with the second sentence.

I can just say "Remove unnecessary rftype flags and improve code readability."

> 
>>
>> Signed-off-by: Babu Moger <babu.moger@xxxxxxx>
>> ---
>>  arch/x86/kernel/cpu/resctrl/internal.h |    9 +++------
>>  arch/x86/kernel/cpu/resctrl/rdtgroup.c |   10 +++++++---
>>  2 files changed, 10 insertions(+), 9 deletions(-)
>>
>> diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
>> index 8edecc5763d8..571145d75d29 100644
>> --- a/arch/x86/kernel/cpu/resctrl/internal.h
>> +++ b/arch/x86/kernel/cpu/resctrl/internal.h
>> @@ -243,12 +243,9 @@ struct rdtgroup {
>>   */
>>  #define RFTYPE_INFO			BIT(0)
>>  #define RFTYPE_BASE			BIT(1)
>> -#define RF_CTRLSHIFT			4
>> -#define RF_MONSHIFT			5
>> -#define RF_TOPSHIFT			6
>> -#define RFTYPE_CTRL			BIT(RF_CTRLSHIFT)
>> -#define RFTYPE_MON			BIT(RF_MONSHIFT)
>> -#define RFTYPE_TOP			BIT(RF_TOPSHIFT)
>> +#define RFTYPE_CTRL			BIT(4)
>> +#define RFTYPE_MON			BIT(5)
>> +#define RFTYPE_TOP			BIT(6)
>>  #define RFTYPE_RES_CACHE		BIT(8)
>>  #define RFTYPE_RES_MB			BIT(9)
>>  #define RF_CTRL_INFO			(RFTYPE_INFO | RFTYPE_CTRL)
>> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> index 15ea5b550fe9..3c86506e54c1 100644
>> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> @@ -3163,7 +3163,7 @@ static int mkdir_rdt_prepare(struct kernfs_node *parent_kn,
>>  {
>>  	struct rdtgroup *prdtgrp, *rdtgrp;
>>  	struct kernfs_node *kn;
>> -	uint files = 0;
>> +	uint fflags = 0;
> 
> Hoe does changing the variable name from "files" to "fflags" simplify
> the code?

I should have said readability of the code. Its actually fflags we are
passing to rdtgroup_add_files. While changing flags below, I changed the
variable name to fflags.


> 
>>  	int ret;
>>  
>>  	prdtgrp = rdtgroup_kn_lock_live(parent_kn);
>> @@ -3215,8 +3215,12 @@ static int mkdir_rdt_prepare(struct kernfs_node *parent_kn,
>>  		goto out_destroy;
>>  	}
>>  
>> -	files = RFTYPE_BASE | BIT(RF_CTRLSHIFT + rtype);
>> -	ret = rdtgroup_add_files(kn, files);
>> +	if (rtype == RDTCTRL_GROUP)
>> +		fflags = RFTYPE_BASE | RFTYPE_CTRL;
>> +	else
>> +		fflags = RFTYPE_BASE | RFTYPE_MON;
>> +
>> +	ret = rdtgroup_add_files(kn, fflags);
>>  	if (ret) {
>>  		rdt_last_cmd_puts("kernfs fill error\n");
>>  		goto out_destroy;
>>
>>
> 
> Reinette

-- 
Thanks
Babu Moger



[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux FS]     [Yosemite Forum]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux