Hi, This builds on Jann's v1 patch[1]. Changes in v3: - fix #if/#ifdef confusion (Bill) - rename from "reason" or "origin" and add it to the warn output (Marco) v2: https://lore.kernel.org/lkml/20221109194404.gonna.558-kees@xxxxxxxxxx/ Thanks, -Kees [1] https://lore.kernel.org/lkml/20221107201317.324457-1-jannh@xxxxxxxxxx Jann Horn (1): exit: Put an upper limit on how often we can oops Kees Cook (5): panic: Separate sysctl logic from CONFIG_SMP exit: Expose "oops_count" to sysfs panic: Consolidate open-coded panic_on_warn checks panic: Introduce warn_limit panic: Expose "warn_count" to sysfs .../ABI/testing/sysfs-kernel-oops_count | 6 ++ .../ABI/testing/sysfs-kernel-warn_count | 6 ++ Documentation/admin-guide/sysctl/kernel.rst | 17 ++++++ MAINTAINERS | 2 + include/linux/panic.h | 1 + kernel/exit.c | 60 +++++++++++++++++++ kernel/kcsan/report.c | 3 +- kernel/panic.c | 45 +++++++++++++- kernel/sched/core.c | 3 +- lib/ubsan.c | 3 +- mm/kasan/report.c | 4 +- mm/kfence/report.c | 3 +- 12 files changed, 140 insertions(+), 13 deletions(-) create mode 100644 Documentation/ABI/testing/sysfs-kernel-oops_count create mode 100644 Documentation/ABI/testing/sysfs-kernel-warn_count -- 2.34.1