Re: [PATCH v2 4/6] panic: Consolidate open-coded panic_on_warn checks

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Nov 14, 2022 at 10:57:15AM +0100, Marco Elver wrote:
> On Wed, 9 Nov 2022 at 21:00, Kees Cook <keescook@xxxxxxxxxxxx> wrote:
> >
> > Several run-time checkers (KASAN, UBSAN, KFENCE, KCSAN, sched) roll
> > their own warnings, and each check "panic_on_warn". Consolidate this
> > into a single function so that future instrumentation can be added in
> > a single location.
> >
> > Cc: Marco Elver <elver@xxxxxxxxxx>
> > Cc: Dmitry Vyukov <dvyukov@xxxxxxxxxx>
> > Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> > Cc: Juri Lelli <juri.lelli@xxxxxxxxxx>
> > Cc: Vincent Guittot <vincent.guittot@xxxxxxxxxx>
> > Cc: Dietmar Eggemann <dietmar.eggemann@xxxxxxx>
> > Cc: Steven Rostedt <rostedt@xxxxxxxxxxx>
> > Cc: Ben Segall <bsegall@xxxxxxxxxx>
> > Cc: Mel Gorman <mgorman@xxxxxxx>
> > Cc: Daniel Bristot de Oliveira <bristot@xxxxxxxxxx>
> > Cc: Valentin Schneider <vschneid@xxxxxxxxxx>
> > Cc: Andrey Ryabinin <ryabinin.a.a@xxxxxxxxx>
> > Cc: Alexander Potapenko <glider@xxxxxxxxxx>
> > Cc: Andrey Konovalov <andreyknvl@xxxxxxxxx>
> > Cc: Vincenzo Frascino <vincenzo.frascino@xxxxxxx>
> > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
> > Cc: Luis Chamberlain <mcgrof@xxxxxxxxxx>
> > Cc: David Gow <davidgow@xxxxxxxxxx>
> > Cc: tangmeng <tangmeng@xxxxxxxxxxxxx>
> > Cc: Jann Horn <jannh@xxxxxxxxxx>
> > Cc: Petr Mladek <pmladek@xxxxxxxx>
> > Cc: "Paul E. McKenney" <paulmck@xxxxxxxxxx>
> > Cc: Sebastian Andrzej Siewior <bigeasy@xxxxxxxxxxxxx>
> > Cc: "Guilherme G. Piccoli" <gpiccoli@xxxxxxxxxx>
> > Cc: Tiezhu Yang <yangtiezhu@xxxxxxxxxxx>
> > Cc: kasan-dev@xxxxxxxxxxxxxxxx
> > Cc: linux-mm@xxxxxxxxx
> > Signed-off-by: Kees Cook <keescook@xxxxxxxxxxxx>
> > ---
> >  include/linux/panic.h | 1 +
> >  kernel/kcsan/report.c | 3 +--
> >  kernel/panic.c        | 9 +++++++--
> >  kernel/sched/core.c   | 3 +--
> >  lib/ubsan.c           | 3 +--
> >  mm/kasan/report.c     | 4 ++--
> >  mm/kfence/report.c    | 3 +--
> >  7 files changed, 14 insertions(+), 12 deletions(-)
> >
> > diff --git a/include/linux/panic.h b/include/linux/panic.h
> > index c7759b3f2045..1702aeb74927 100644
> > --- a/include/linux/panic.h
> > +++ b/include/linux/panic.h
> > @@ -11,6 +11,7 @@ extern long (*panic_blink)(int state);
> >  __printf(1, 2)
> >  void panic(const char *fmt, ...) __noreturn __cold;
> >  void nmi_panic(struct pt_regs *regs, const char *msg);
> > +void check_panic_on_warn(const char *reason);
> >  extern void oops_enter(void);
> >  extern void oops_exit(void);
> >  extern bool oops_may_print(void);
> > diff --git a/kernel/kcsan/report.c b/kernel/kcsan/report.c
> > index 67794404042a..e95ce7d7a76e 100644
> > --- a/kernel/kcsan/report.c
> > +++ b/kernel/kcsan/report.c
> > @@ -492,8 +492,7 @@ static void print_report(enum kcsan_value_change value_change,
> >         dump_stack_print_info(KERN_DEFAULT);
> >         pr_err("==================================================================\n");
> >
> > -       if (panic_on_warn)
> > -               panic("panic_on_warn set ...\n");
> > +       check_panic_on_warn("KCSAN");
> >  }
> >
> >  static void release_report(unsigned long *flags, struct other_info *other_info)
> > diff --git a/kernel/panic.c b/kernel/panic.c
> > index 129936511380..3afd234767bc 100644
> > --- a/kernel/panic.c
> > +++ b/kernel/panic.c
> > @@ -201,6 +201,12 @@ static void panic_print_sys_info(bool console_flush)
> >                 ftrace_dump(DUMP_ALL);
> >  }
> >
> > +void check_panic_on_warn(const char *reason)
> > +{
> > +       if (panic_on_warn)
> > +               panic("%s: panic_on_warn set ...\n", reason);
> > +}
> > +
> >  /**
> >   *     panic - halt the system
> >   *     @fmt: The text string to print
> > @@ -619,8 +625,7 @@ void __warn(const char *file, int line, void *caller, unsigned taint,
> >         if (regs)
> >                 show_regs(regs);
> >
> > -       if (panic_on_warn)
> > -               panic("panic_on_warn set ...\n");
> > +       check_panic_on_warn("kernel");
> 
> What is the reason "kernel" in this context? The real reason is a WARN
> - so would the reason "WARNING" be more intuitive?

I'll rename "reason" to "origin" or something -- it's mainly to see
who was calling this when it's not core kernel logic.

-- 
Kees Cook



[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux FS]     [Yosemite Forum]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux