On Fri, Oct 25, 2019 at 10:45:31AM +0100, Yunfeng Ye wrote: > On 2019/10/25 17:33, Ard Biesheuvel wrote: > > On Fri, 25 Oct 2019 at 09:24, Yunfeng Ye <yeyunfeng@xxxxxxxxxx> wrote: > >> > >> Warning is found by the code analysis tool: > >> "Redundant condition: accel_dev->is_vf" > >> > >> So remove the redundant condition accel_dev->is_vf. > >> > >> Signed-off-by: Yunfeng Ye <yeyunfeng@xxxxxxxxxx> > >> --- > >> drivers/crypto/qat/qat_common/adf_dev_mgr.c | 4 ++-- > >> 1 file changed, 2 insertions(+), 2 deletions(-) > >> > >> diff --git a/drivers/crypto/qat/qat_common/adf_dev_mgr.c b/drivers/crypto/qat/qat_common/adf_dev_mgr.c > >> index 2d06409bd3c4..b54b8850fe20 100644 > >> --- a/drivers/crypto/qat/qat_common/adf_dev_mgr.c > >> +++ b/drivers/crypto/qat/qat_common/adf_dev_mgr.c > >> @@ -196,7 +196,7 @@ int adf_devmgr_add_dev(struct adf_accel_dev *accel_dev, > >> atomic_set(&accel_dev->ref_count, 0); > >> > >> /* PF on host or VF on guest */ > >> - if (!accel_dev->is_vf || (accel_dev->is_vf && !pf)) { > >> + if (!accel_dev->is_vf || !pf) { > > > > I disagree with this change. There is no bug here, and the way the > > condition is formulated self-documents the code, i.e., > > > > IF NOT is_vf > > OR (is_vf BUT NOT pf) > > > > Using an automated tool to reduce every boolean expression to its > > minimal representation doesn't seem that useful to me, since the > > compiler is perfectly capable of doing that when generating the object > > code. > > > ok, thanks, this modify just fix warning, and make code simple. This change simplifies the code but it makes it less readable. I'd prefer to leave it as it was. Regards, -- Giovanni