Quoting Nathan Lynch (nathanl@xxxxxxxxxxxxxx): > Something I missed earlier is that the stack_size you are passing in > from user space is not actually the size of the stack. It's adjusted to > account for arguments that have been placed at the end of the stack > region. So stack_size becomes a value that you want the kernel to add > to stack_base to get the desired stack pointer value in the child -- > it's not a size at all. At this point we may as well communicate the > desired stack pointer value directly (which could be denoted by > stack_size == 0, or we could add another member to clone_args), or > rename stack_size to stack_offset or similar. So do I understand correctly that the agreement (reached on irc) is to keep passing in a stack_size, but enforce that it ==0 for all but ia64? -serge _______________________________________________ Containers mailing list Containers@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/containers