On Tue, 2009-04-28 at 19:23 -0400, Oren Laadan wrote: > +struct ckpt_pgarr { > + unsigned long *vaddrs; > + struct page **pages; > + unsigned int nr_used; > + struct list_head list; > +}; > + > +#define CKPT_PGARR_TOTAL (PAGE_SIZE / sizeof(void *)) > +#define CKPT_PGARR_CHUNK (4 * CKPT_PGARR_TOTAL) I seem to get irrationally angry in the presence of 'clumps', 'chunks', and other non-descriptive variable names in mm code. :) Anyway, this is only used in one place, but it might be better to call it: CKPT_PAGES_AT_ONCE or CKPT_PGARR_BATCH Batching up 4 at once doesn't seem that great of a win to me. Why bother adding another loop and another variable unless the batch size is bigger? -- Dave _______________________________________________ Containers mailing list Containers@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/containers